A Bell Tower Setback

I procrastinated writing a blog post about the UV mapping progress last week. Each night after work, I’d spend some time in UV Layout unwrapping parts of the bell tower model. Then on Friday night, I hit a snag.

discontinuous_edgeA snag that would end up stomping on all my work thus far.

UV Layout displays discontinuous edges in blue. What is that? An edge that is part of only one polygon. A two dimensional square would have four discontinuous edges but a three dimensional cube would have none because all edges are shared by two polygon faces. These are not bad things necessarily – a modeler might create them on purpose.

In the picture above, the red arrows point out four polygons. Each of the two pairs on either side of the blue line should be sharing that edge. You can see other blue, discontinuous edges in other parts of the picture.

discontinuous_edge_2The ultimate proof of the problem is in LightWave itself.

On the left, it looks like I have selected a single point. However, the Point Info dialog box clearly shows two points. Each point has the same Z and Y coordinate location; but the X coordinate is off by 0.1192 micrometers.

That is smaller than a lot of bacteria. But it still means that there are two different edges that look like one edge to the naked eye.

I don’t know how this happened. A good thing that LightWave has a super-easy fix with the Merge Points command!

So all is well right?

I thought it would be. But UV Layout refuses to open the new OBJ file that I saved. The error message it displays is not helpful at all.

So I am taking this force-fed opportunity to clean up the model geometry a little bit before re-starting the UV mapping process from scratch. The shape will be unchanged; I am just tweaking areas that will improve the ease of UV mapping.

Hopefully the next major release of LightWave will see some huge improvements to the UV toolset. Otherwise, I might finally abandon LightWave in favour of Modo.